Monitoring Google Cloud Networking Issue

Incident Report for Numa

Resolved

Google Cloud and Twilio API operating normally

The previous outage has been fully resolved. Calls and messages are handled properly and we are operating normally.
Posted Sep 01, 2026 - 11:50 PDT

Update

We're aware of an issue with our telephony and messaging provider, Twilio, that is affecting calls and text messages. You may experience problems with click-to-call, outbound SMS, call routing and call recording.

We're actively monitoring the situation and will share updates as we learn more.
Posted Sep 01, 2026 - 10:34 PDT

Update

Google Cloud has reported that recovery is in progress. Impact to Numa has been minimal, and we have not observed widespread customer-facing issues. We'll continue monitoring closely until Google confirms full recovery.
Posted Sep 01, 2026 - 09:17 PDT

Investigating

We're aware of a partial networking issue with Google Cloud, a provider we rely on. As a result, some services may be intermittently slow or return errors. We're monitoring the situation closely and will share more updates as we learn more.
Posted Sep 01, 2026 - 08:25 PDT
This incident affected: Numa Inbox.